L298n-dual drive nodes don't work

I have attempted every node in the library to no avail. I am trying to run 2 DC motors. It does work programming with Arduino code but not XOD. I love the XOD so this is frustrating.

Can you show is how you are trying to use the driver?

Thanks for getting back to me. I am using the l 298 module to drive 2 dc motors for a robot. I noticed the bridge node was outlined in red. I have tried several of the other l298 driver nodes but I am having no luck. I wrote the code in Arduino code and the driver and motors worked. I have attached the patches I am using.


(Attachment patches l298.docx is missing)

Here is the library that I need but it is corrupted.

I assume that is the gweimer/h-bridge/h-bridge-2dir node since it does not exist in XOD std release. Looks like latest update has broken it.

It is a copy of the standard h-bridge-dc-motor that adds the !DIR pin and performs an additional digital-write to that pin, writing the opposite of what is written to DIR pin (hence the “not” node).

I can try to update the library. If you don’t want to wait for me, you can make your own by making a copy of the h-bridge-dc-motor node and adding the code for the 2nd DIR pin. Note that the new version will have an ACT pin that you will need to manage.

gweimer/h-bridge library has been updated for XOD 0.31.x

1 Like

Thanks for the update. My robot motors are working perfectly. I am starting to teach my Boy Scout Troop how to use XOD. Its exciting.

Alan Burdick

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.