[I want a node] RGB LCD I2C Adafruit 5 Button shield

RGBLCDI2C-5 button shield

A short description of the node as it should be seen in the docs A five button 5 color 2x 16 or (4x 20) I2C node using library’s
// include the library code:
#include <Wire.h>
#include <Adafruit_RGBLCDShield.h>
#include <utility/Adafruit_MCP23017.h>

// These #defines make it easy to set the backlight color
#define RED 0x1
#define YELLOW 0x3
#define GREEN 0x2
#define TEAL 0x6
#define BLUE 0x4
#define VIOLET 0x5
#define WHITE 0x7

Inputs: Init,addr,rows,cols,(BL,or BL color),L1,L2,L3,L4 Similar to Gweimer LCD I2C

  • INa (number, default=1) — the description as it should be seen in the docs
  • RST (pulse, default=never) — the description

Outputs None

  • OUT (number) — the description

Extra info: rationale-Color is cool, the 5 button shield is very useful without occupying many pins.
, edge-cases, details

hi, you can try this cesars/rgblcd , I do not have the hardware, so it’s very difficult for me to know if it works well

Thanks this looks like just what I am looking for. I tried to add the library and got this message “library/various has no version latest”
I’m new at this and not sure what is wrong.

look no problem

I have loaded several librarys including yours but when i load the lib cesars/rgblcd i am still getting the previous error

  • library/various has no version latest

  • library/various has no version latest

  • library/various has no version latest

Can you try another one now? I will upload a higher version, to see if it is solved v0.0.6

I am still getting the same error with cesars/rgblcd
I was able to install your 8 bit register with no problem

it shows up as rev 0.0.6 after I type it in but gives the same error

close XOD, and reopen

Good morning, Thank you for your help on this. I have rebooted,tried it on another computer and loaded your entire set of nodes they all loaded except The “cesars/3-digit-multiplex-7seg” and “cesars/rgblcd” The error i got for the 2 is similar but not exactly the same.
I have included a screen shot with my cellphone sorry for the low quality. I’m not sure how to capture the XOD image

This library is not working, I recommend the following of Bitrex

look for the __lib__ folder inside XOD in Documents, copy this github folder in cesars folder, or another new folder.

You can capture with ImprPrint key and then paste and edit in Paint or other software.

I was able to get the file from Github and loaded it but when XOD loads it gives the error but the file showed up and found the error in the color node expanded to the if-else-v, I do not have a multiple input if-else-v, the only one i have is the single input node on the image

Sorry, that node is a version of mine .cpp, load the following, arranged in github you can download again


Thank you very much
What is the name of that node

gweimer/utils has an if-else-v, but I haven’t checked it against recent XOD versions.

yes, I committed the error of including in the library, the one that modifies in C ++, and not the original gweimer/utils

I just do not understand how does a single if-else-v become a 7 input single output -----Scratch that
Aha I replaced the if-else-v with the Gweimer one into the cesars/rgblcd directory and now the program can find it

no error

now i need to put it to use. I’ll keep you posted

Thanks All

Inside the node there is a variadic-2

Cesar where is the I2C address of 0x20 get entered for the node