I can not connect the DS18B20

A very common temperature sensor DS18B20. First I connected this scheme.

Then I realized that I had to connect not to D2, but to A2.

There was a reaction to my connection to this port, but the temperature data is not correct.

Hmmm… That’s because you’re trying to read DS18B20 sensor with a node for TMP36 thermometer which is absolutely another piece of hardware.

DS18B20 is not supported out of the box yet. Although you can create a node to read it in C++. See recent guide articles to learn how. If it’s too hard for you, I can only suggest waiting until someone implements it and publish as a library.

I wanted to support the DS18B20, but I’m short of time, so can’t promise when I could done it.

Many thanks, for attention to my little problem.
Yes, it’s difficult for me, but I’ll still try to figure it out, since if I do not use XOD, then the sensor works fine, but in XOD excellent procedures for visualizing the process of the contender. But as Socrates said: Who wants (ds18by20), he wants opportunities, who does not want - he searches for reasons (not supported).
As I understood, the main problem is that the sensors can be several OneWire, Tell me how to work with OneWire modules.

OK, OK… Here is your cake :wink:


Add the nkrkv/ds18b20 library and you’re ready to work with your DS18B20 like with any other thermometer.

Many thanks for such a wonderful New Year gift.
Cool! I also learned how to add libraries …

Try to connect and to d7 as in the example. Tried in A0 and d0. The port at XOD exhibited the corresponding. I tried in XOD to put port 3 and connect to a3 and d3 when debugging my zero readings of the sensor.


Tra to trigger UPD with a clock pulse.

1 Like

Oh, good catch! @maiklbaklan in its current setup the update is only made once, on boot. Looks like the sensor has not enough time to complete temperature conversion. Set UPD to Continuously.

comrades, do you think I have not tried Continuously

Oh, I just did not drive around the sensor, so nothing happens.

Unfortunately, my sensor works:

Sorry for shaking :blush:

Anyone who also has a DS18B20, please, check it with XOD too. So I could better understand the source of the problem. Is it something wrong with my sample or the one @maiklbaklan has? Or maybe there’re several models exist with slight differences in protocol.

Shaking hands - do not worry! You’re not a professional cameraman. From your video, everything is clear.
Russian New Year’s miracle. In Russia before 1917 there was a calendar different from the current one. In the tradition there is a celebration of the Russian New Year, this occurs from 13 to 14 January. The same sensors, one and the same arduino, now worked, turned on two temperature sensors.

And even three sensors. Connected to ports 2, 3, 4.
The second sensor I hold in my hands, because it shows a high temperature.
Comrade, great respect for your attention to your followers.
Thank you.
P.S. I’ll go have a drink of vodka and play a balalaika with my bear :slight_smile:


Glad to hear they started to work! Please, mark the topic as solved if you think so (three dots button → checkmark icon).

:rofl: Do not forget a matryoshka and shapka-ushanka hat

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.