Error While downloading Dependencies

I have just downloaded this program and while performing the first upload to the Arduino I was required to download some dependencies I got the following error.
Process exited with code 2
The error has no formatter, which is a bug. Report the issue to XOD developers.
Could someone help with this?

As it turned out I have found that uninstalling Xod and reinstalling has overcome this problem.

I have this same error, and reinstalling the XOD sw did not help.
Welcome anyone’s input.

errors so do if temporary files are deleted, sometimes closing and reopening XOD fixes it

I’m struggling issue, have tried reinstalling the XOD software, did not help.
Also tried exiting and reopening software also no help.
Really like the concept, hope can get to work.

It seems like a permission error, try to open XOD in administrator mode

That was a good idea, unfortunately it didn’t do the trick either.
Just wanted to say, thanks for your help.
Just a thought, do you know how to contact the “XOD developers” as suggested
by the error dialog box?

there is an installation error the package ESP8266, just done the test
notice for @nkrkv @evgenykochetkov @brusher_ru

1 Like

Is there anyone at XOD that can be contact, some sort of Tech Service, that I can contact to help my with this issue? I’m very new to this XOD thing and would love to learn it’s features, But right now can’t get past 1st base. Please anyone help!!

Sorry. There is no Technical Support/Service. This is developed by volunteers and is still considered Alpha software. Unfortunately, the developers have been unusually quite lately. Hopefully this is a temporary issue…with any luck, it is because they are neck-deep working on the next release…

gweimer and all others, thank you for your assistance, rather disappointed, but understand this is an Alpha software. Hopefully when I get my other PC back that might work. Can’t see any-other way to go for now.

I have already given notice to the developers, you should wait for an answer, maybe it is a problem of the esp8266 repository

Thank you. FYI; just picked up my other PC (laptop), from shop.
Loaded XOD software, and have identical issue !
I will await more info/solution from developer
Once again thank you for your kind assistance.

Alternative solution:

Open file extra.txt in C:\Users\ ~you_user~ \xod\ __ packages__ \ and change firts line by

Open XOD … try now

Found the file “extra.txt” and changed to "". Looks like I got same error.

you have another problem because I have loaded it without any error.

try loading it into Arduino ide … in preferences then manage boards

copy C:\Users\you_user\AppData\Local\Arduino15\packages\ “ESP8266” folder

Still hoping for a solution. Did I mention I have tried this on 2 different PC’s?
With same error.

yes, but when change the link extra.txt I had no error, the same link in Arduino IDE gave me error and the modified one did not.

Has the Arduino IDE installation tested as I said before?

Today I reinstalled XOD ,about the 4th time. This time it worked no problem. Have yet to try on my other PC. Much relief!!! Still though no definitive solution, unless you go by…
“TRY,TRY,AGAIN”, whatever glad it’s working.