Elechouse PN 532 issue

Hi All

I have been playing with the PN 532 but have hit the wall with it . Using Cesars PN 532 library I can pull back a Firmware version but that’s it .
Using the other Nodes ie unpack UID just gives no results . I am using the board connected as an I2C Device and have a separate line for IRQ to A0 as requested by the Node . I dont have a lot of Hair to start with but this problem is causing it to rapidly diminish :slight_smile: , Any Help or advice would be gratefully received . Thanks

hi, for 532 use the XOD native nodes, my library is for rc522

Hi Cesar , Thanks for replying . I am using the 532 Native node ( apologies , i was rushing doing the inquiry) . Iam not convinced I have the connections correct though . I have tried the SCL SCA connections nearest the USB socket on the UNO and various other configurations but do not seem to be getting very far ( are pullup resistors needed ?). Would you be able to confirm the connections ? .
XOD is a Great piece of software and has opened Arduino up for me . Love it

Hi

Seems I have some Library issue . I was getting a few different errors so removed the libraries and reloaded them . I now get .
In file included from
C:\Users\MarkC\AppData\Local\Temp\xod_temp_sketchbookRIOHoH\xod_1588242680825_sketch\xod_1588242680825_sketch.ino:979:0:
C:\Users\MarkC\AppData\Local\Temp\xod_temp_sketchbookRIOHoH\libraries\Adafruit_PN532/Adafruit_PN532.h:222:3: error: ‘Adafruit_SPIDevice’ does not name a type; did you mean ‘Adafruit_PN532’?
Adafruit_SPIDevice *spi_dev = NULL;
^~~~~~~~~~~~~~~~~~
Adafruit_PN532

thanks

So I tried numerous things . Stripped off xod then reloaded and installed the libraries through xod for PN532 . When i do this i get
In file included from C:\Users\MarkC\AppData\Local\Temp\xod_temp_sketchbookHkW3th\xod_1588247553753_sketch\xod_1588247553753_sketch.ino:979:0:
C:\Users\MarkC\AppData\Local\Temp\xod_temp_sketchbookHkW3th\libraries\Adafruit_PN532/Adafruit_PN532.h:34:10: fatal error: Adafruit_SPIDevice.h: No such file or directory
#include <Adafruit_SPIDevice.h>

Any help advice would be most tremendous , Thanks

When trying to compile a light blue warning appears, you must click to download the library and recompile.

If not downloaded, you should do it manually from

and add the unzipped folder in /user/xod/__ardulib __/

Hi Cesar

Thanks for the information . I still get the error but looking in the unzipped package I dont see the SPI file .

Follow these steps

capture ![error|690x57]

Hi , I have tried on a different PC but get the same issue . I have attached an image of the ardulib directory . It seems to me that there are some files for SPI support missing from the GitHub library ??

download this zip and repeat the previous process

Capture

Hi , I used a different library and now it compiles . Image attached

still no comms but a bit nearer :slight_smile:

So I just tried the PN532 directly through the Arduino IDE and UNO says hello but nothing back from the PN532 so I am pretty sure the board is a duffer . Thanks for your help its been a good learning experience

I can not contribute any experience with PN532, because I do not have that hardware.
I only have the rc522 for which I made a library but it is not yet complete

Br

I have an RC522 also . Is the library you have for it so far capable of unpacking the card UID ?