Desktop IDE on Raspberry Pi4

Has anybody had any success compiling the source code for the XOD Desktop IDE to run on Raspberry Pi OS?
Ive been following the instructions, but keep getting errors, some of which I have worked through and fixed, like the incorrect version of Yarn that gets installed when you “sudo apt-get install yarn”.

I would really like to use the desktop IDE on my Pi4, I’m not a fan of the web version.
Please note I am not talking about compiling XOD code to run on the Pi, I want to code for the Arduino from my Pi.

Anyone?
I’ve narrowed part of the problem down tot eh fact that Yarn tries to install a dependency wilt the wrong arch type. Electron-chromedriver removed the arm arch in favour of armv6l and armv7l.
I’ve look to try and correct this, but I’m no developer so have had no luck fixing this. Is there a developer here that can point me in the right direction so I can get this working.
Here is a copy of the error when I run yarn.

[6/9] ⢀ @serialport/bindings
[2/9] ⢀ node-sass
[3/9] ⢀ puppeteer
[4/9] ⢀ electron-chromedriver
error /home/pi/github/xod/node_modules/electron-chromedriver: Command failed.
Exit code: 1
Command: node ./download-chromedriver.js
Arguments:
Directory: /home/pi/github/xod/node_modules/electron-chromedriver
Output:
/home/pi/github/xod/node_modules/electron-chromedriver/download-chromedriver.js:19
if (err != null) throw err
^

Error: Failed to find Electron v3.0.0 for linux-arm at https://github.com/electron/electron/releases/download/v3.0.0/chromedriver-v3.0.0-linux-arm.zip