Can we please have download packge for Raspberry pi

I want to use on my Raspberry Pi. Right now I don’t think it’s possible to get it running. Can you please release a version of that will work on the Raspberry Pi. You might even be able to have raspberry pi foundation add it as default software on their operating system because I think they would agree that isna great program to use and would be beneficial of their goals. So it would be win win for every one. Please

Not an “official” response, but this has been brought up before. Technically, XOD is still in Alpha (maybe Beta?) release. There are plans to eventually release for other platforms like the Raspberry Pi, but the developers wanted to be able to initially focus on improving XOD rather than supporting lots of platforms. We don’t hear from the developers on this forum as much as we did when I first joined several years ago, but they do keep coming out with new releases; sometimes with significant changes that require rewrite of existing patches to continue working as they make major improvements or add functionality.

I have tried a few times to compile it myself on the RPi.
The problem is there isn’t clear instructions for compiling it from source code.
It just says
“XOD is written in JavaScript and ReasonML. You need Node.js and Yarn to build from source. Make sure they are available on your system.”
Problem is they don’t mention which versions of each package need to be installed. Also, If you install Yarn from the repositories, its the wrong Yarn. For a while the installer was calling for the wrong ARM packages, although this has now been fixed.
Each time I’ve tried, I get a little further, but it always errors out with a version issue of a package that isn’t documented.
In the end I just gave up. I really want to be able to use the RPi, but it will never happen until the devs provide some clearer instructions.

Hi…the document is a shell that attempts to do savvy things by introducing missing bundle… Which won’t work there. You ought to examine the content to get what is the parallel to run and attempt to simply run this…

There will be, presumably, some missing x86 library to assemble.

first clue: when the content request the secret phrase for sudo, just Ctrl-C and it will proceed without attempting to introduce the dependancies.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.