XOD on Windows 32-bit

hey everyone, the first thing i want to do is to thank the people who created this masterpiece, it’s a nice envirement of work and programming, it’s similair to LABVIEW, almost the same technics and stuff.
second thing i need help, i have a 32 bit windows !, i didn’t find any compatible software with my operation system, so please give me a link to download the 32 bit version of the XOD ide.
Thanks in advanced

Moderator note :exclamation: Title changed to make the topic more clear

1 Like

Hello and welcome!

Unfortunately, we’re not supporting desktop IDE for 32-bit Windows. It is pretty archaic configuration. We use the time saved by dropping 32-bit support for developing new core features. I suggest using browser-based XOD IDE (it works everywhere) or, of course, updating OS is an option.

thanks for your reply, any plans for creating a version for 32 bit systems in the near future ?

A little research has to be done. I’m not sure will we have problems building 32-bit or not… to be honest we don’t even have a 32-bit PC in the office to check it. So can’t predict it for sure.

you guys will do a big favor for us if you created a 32 bit version, please take my request in consideration, and if it’s not so difficult to build a version, please build one for me, a simple version is enough


A pity that you do not do it for 32bits because many people who use arduino boards have PC with this architecture and especially for teaching in schools.

Well, OK, 32-bit Windows is something we should not ignore if its support does not require a huge portion of work. I’ve put an issue on it.

No ETA yet. Show your support for the feature with :heart: of the thread or the issue on GitHub.


Hello, folks!

Here we have a prerelease build that should work on Win 32-bit. I have no easy way to test it since we have no such PC’s in our office. Would you check?

There two critical points where something could go wrong:

  1. IDE installation and the first start. If you see the window and can create nodes — fine!
  2. Board upload. Try to upload a program (blink or something) from within IDE. If it succeeds, woohoo!

If something goes wrong, please post a detailed sequence of actions you perform. Attach any errors you have seen verbatim. Screenshots would help also.



I tried to install this version on my 32-bit XP PC. After starting the installation procedure a message popped up which says WIN7 is required and the process was aborted.

@dox Well, now we know Windows XP is not supported. At this level Electron framework (XOD build upon it) defines what’s possible and what is not. XP should really join a party with Win 98 and Win ME :balloon::zombie:

Thank you for spending your time on the test.

thank you very much for the 32-bit version of XOD! I really like your program, I will learn and help you!) I’m working and downloading!) if you can create the option to do not through C ++ and through the same as in the IDE do, and then I do not know C ++ but I know IDE))

Not quite sure what do you mean, @misha-2003-xod :slight_smile: Does the 32-bit works for you? Have you successfully uploaded a program to the board?

i can’t enter the forum brother :frowning: it’s been a whole week, i want to share my experience

I live in Ukraine.
my program works.
Everything is as it should be.
I really like it.
I want to help you in the development of your project.
You can all say that now there is a robot 32-bit version!)
if you can create an opportunity to program blocks through Arduino IDE.
I do not know C ++, but I know the IDE.
I hope you understand))
success in your development!)

Hey everyone, i tried it and it doesn’t work for me, it stop at the upload operation, this is the message :


:heavy_check_mark:Upload Log
Watched Values

· Transpiling…
· Project was successfully transpiled. Searching for device…
· Port with connected Arduino was found. Installing toolchains…

Installing of toolchains could take some time depending on the speed of your Internet connection.

If repeated attempts and a long waiting does not help, try to install toolchains manually. Here is detailed instruction: Can I manualy install the toolchain?.

If this does not help, try to mark “Compile in the cloud” option in “Upload to Arduino” dialog and please write some information to help us make it working for you:

  • which OS you are using,
  • Board model,
  • which port did you selected,
  • does compilation in the cloud helped?


hey, thanks for your response, i will try to follow what you just said, and btx i’m using : windows 7,Arduino Nano,i choose port 8, D8, and for that cloud compilation i didn’t tried it yet, i will answer you right after i test it. Thanks

Your link is not working. nkrkv, can you give a new link?

Currently XOD does not work on win 32, all available versions are here https://xod.io/downloads/

and here

@misha-2003-xod Hi Misha we here Ukrainians as you are )) Did you succeed in 32-bit release downloading and installing? Well it seems you did, but I did NOT for now - it writes a kind of error message when I try to download ‘prerelease 32-bit version’… If you’ll comment it some way, I’m happy… Have a nice day! Alexey.