Tabtest, crashed. (Win10. 0.26.0)


#1

Thanks for good capability “tabtest”.

Some crazy men(like me!) are trying doing something strange or weird.

  1. I tried build a abstract patch that has tabtest in it and I got Error messsage.
    and tabtest is runing until exit of IDE.
    “Pin type should be “pulse”, “boolean”, “number”, etc, got “t1”
    The error was not caught, which is a bug. Report the issue to XOD developers.”

  2. When I tried a tabtest in a patch that has abstract patch. I got
    “Maximum call stack size exceeded” and tabtest is runing until exit of IDE.

  3. You can download them from “koadrobot/koad” in library.


#2

node iless deprecated, node minimum includes deprecated iless why?
also you must select the type in inspector



I happen the same here, it does not stop


#3

I just saw that together with generics, number-type nodes were created, just like with oneself, I had not read about that…


#4

Thanks, @koadrobot for the detailed report! The tabtests is a new feature and it is very likely we’ve overseen some scenarios. Abstracts can be one of them. We’ll take a look when return back from the New Year holidays.

Meanwhile, the recommended way to deal with testing generics is creating dedicated test patches which unwrap the complexities to primitive types. See https://xod.io/docs/guide/testing-patches/#variadics-generics-custom-types