XOD Install & 1st upload without Internet connection

I put XOD install .exe on a thumb drive & asked my students to install it in class, which went fine, but on first upload to Arduino, they got an error message about unable to access a URL. I assume this was for Arduino Uno-specific data needed to do compiles. After error, upload just hung. After connecting to internet and trying to upload again, it just hangs and apparently is assuming data was downloaded, but it is not available.

Uninstalling XOD & re-installing did not resolve the issue. How do I fix their XOD install now? How do I install all required files so internet connection is not needed next time?

2 of the computers are Windows 7 Enterprise (not sure what the 3rd one is). I was able to login as a different user & get XOD install for that user working, but original user still does not work.

Making original account an Administrative account doesn’t help. I’ve copied <user>/xod and <user>/AppData/Local/Programs/xod-client-electron from working account to original, but it has not helped. Uninstalling & re-installing by running install as Administrator did not help.

I’m out of ideas…

Upload just hangs at:

Project was successfully transpiled. Searching for device...
Port with connected Arduino was found. Installing toolchains...

Hmmm…I just created a new user on the same box & tried install (which worked), but 1st upload produced JavaScript error:

Uncaught Exceptions:
at Bzip2Error (C:\Users\Dummy\AppData\Local\Programs\xod-client-electron\resources\app.asar\no…:19)
at Object.bzip2.header (C:<same path>\app.asar\no…:37)

There is more, but it won’t let me copy & path to code is truncated anyway. Clicking OK gives the error I saw before (students must have clicked through the other screen):

Could not install tools: FetchError: request to https://storage.googleapis.com/releases.xod.io/packages/win32-avr-tools.tar.gz failed, reason: connect ECONNREFUSED

UPDATE: Looks like internet access was being blocked at the time I got the above error. I created another new account (without admin access) and I was able to successfully install XOD and upload; 1st upload just takes a long time since it is downloading avr-tools with no indication (that I saw) that it is doing that.

I still don’t have a way to fix the original account that seems to have some sort of corruption.

Finally found it. It is something under /AppData/Roaming. Not sure how to narrow down what is needed to avoid having to download from internet on 1st upload…

Taking a guess, I think what happened is we tried 1st upload without internet connection and got the error that we couldn’t connect to server to download avr-tools. We then had a bad internet connection and got the same error. Then we connected to a hot-spot on someone’s phone & all 3 students tried to download the file at the same time. We assumed it wasn’t working and tried to restart while the file was being transferred (not realizing it was attempting to transfer a large file), giving us a corrupt file. Future upload attempts seem to be getting hung on the corrupt file.

Looks like to avoid internet connection on 1st upload, the win32-avr-tools.tar.gz file needs extracted in c:\Users<user>\AppData\Roaming\xod-client-electron\packages\arduino\tools (untested; I copied that folder from a working account & over-wrote all files; I’ve spent too much time on this & need to do work that pays the bills…).

Oops. Yeah, we should make this experience more explicit and simple.

Bug :beetle: , thanks!

Yep, the full recipe is here: Can I manualy install the toolchain? - #2 by brusher_ru

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.