text-lcd-16x2-i2c


#1

AM NEW TO XOD AND HAVE PURCHASED THE 1602 LCD WITH THE I2C INTERFACE.
WHEN I SELECT THE PATCH FOR IT THE PATCH ONLY DISPLAYS A GREEN RECTANGLE
AND WITH ONLY TEXT DISPLAYED AND NOTHING ELSE
ALL THE DEMOS I HAVE WATCHED SHOW ALL THE PINS FOR CONFIGURING THIS DEVICE.
I HAVE DELETED BOTH XOD IDE AND ARDUINO SOFTWARE SEVERAL TIMES AND RELOADED THEM AGAIN WITH THE LATEST VERSIONS WHICH I WAS USING IN THE 1ST PLACE AND EVERY TIME I SELECT THIS PATCH IT IS THE SAME STORY BUT IF I SELECT THE SAME DISPLAY WITH THE PARALLEL I/F IT SHOWS ALL THE CONNECTING PINS
PLEASE I NEED HELP AS I REALLY LIKE WHAT I SEE,
Please can some one give me some hint how to address the problem i have with the "text-led-16x2-i2c node when i select it.
i cannot get it work even now that i loaded the very latest version of XOD .this morning
It still only shows the small green rectangle with no pins and "text " in the center.


#2

It seems to me that you are dragging an example to a patch.

If it is an example you must double click.

Write with lowercase, understand better.


#3

many thanks for your suggestion,this is how I think my issues came about
As i am very new to xod , when i selected this patch for the 1st time it did not bring up the image of the patch i had seen in all the examples,videos and the tutorials.
It brought up on the patch only the pins and i though i had made a mistake in my selection
of the node.as the pins were spread apart i then deleted them as one block but i must have missed the green rectangle for the text.and now every time i select this patch i only get the green text rectangle and cannot get rid of it.
I have deleted xod and arduino software and reloaded several times .
i cannot get it work even now that i loaded the very latest version of XOD .
It still only shows the small green rectangle with no pins and "text " in the center.
Thanks again and have a good day.


#4

ok, I think I understand better now
you opened the patch (a node in reality) and eliminated the pins, only it was left no-implemented-in-xod

to fix it, delete the XOD folder of my documents and run XOD again

The nodes must be added to an empty patch by dragging, if you double-click them, you will see the content.
The examples are opened with double click, but … an example(an patch) can work as a node, adding the corresponding terminals


#5

Once again many thanks

Kind regards

David Baxter


#6

Thanks I have followed your instructions and it has cleared the problem and works now.
While I have your attention is there any way to print out a printed copy of a patch.
Once again thanks.
Kind regards
David.


#7

only with zoom adjustment and screenshot


#8

once again thanks
Kind Regards
David