Rf 434 mhz transmitter and receiver

#1

RF transmitter/ receiver

Receive and interpret code from an RF remote , Transmit a known 433 Mhz RF code to a 433 Mhz device , Record and play back a 433 Mhz RF remote signal

Inputs

  • PORT (number, default=12) — which port the transmitter/ receiver connected
  • UPD (pulse, default=never)
  • Send data (number) — Transmit code to receiver

Outputs

  • Data received (number) — Receive code from an RF remote

Thank you

0 Likes

Library for receive / send IR
#2

Hi splcarlab

Something like this?
https://xod.io/libs/bradzilla84/433mhz-rcswitch/

let me know how you go.

1 Like

#3

Man, that’s exactly what I needed,And even more Thank you,Thank you,Thank you,

0 Likes

#4

No problem… My pleasure.

0 Likes

#5

How did you go? any problems?

0 Likes

#6

i had tryed library. Receive is ok but trasmit cannot work. Anyone had probe it? (its ok pinout 10 is D10 ?)
i used

thanks a lot

0 Likes

#7

Hi dinosalvioni
What problem were you having with Transmit?
I tested it with Example-Repeat with no problems on a set of “Watts Clever” GPO Switches.
I have updated the Lib with the new Watch nodes to.

0 Likes

#8

works great for me , decode most chinese car remote control

0 Likes

#9

Sorry, now it works fine in stand alone and in simple program.
But i had to try a more complex program with (bitrex/xod-menu-system) and rf node “433 receive” start but dont work (interrupt dont receive siglal or similar effect). Rf433 send not works!
I suspect it is something related to interrupt management in complex program.
How XOD operate with interrupts?

Any comment and workaround is welcome.

I Use Arduino Mega

Thanks a lot

0 Likes

#10

My experience with interrupts is that Arduino reuses interrupts for multiple tasks, like timers and PWM generators. Since XOD does not allow you to select interrupt for timer, you have to resolve any conflict by using a different PWM pin. I don’t know how you could resolve conflict if a library is conflicting with a timer.

0 Likes

#11

Sorry can you check your repeater example program of rf433 library. it dont works: after 10 seconds (first cicle of clock) where it receive (but dont trasmit on other shield) program stop to receive.

i had also many problem to trasmit, but my shield with https://github.com/sui77/rc-switch/blob/master/examples/SendDemo/SendDemo.ino works right
insted receiver works fine

i dont know where is problem but with other scripts my hardware go right

thanks a lot

0 Likes