Problems compiling


#1

I am unable to compile anything. I’m running Windows 10. Just getting started with this but here is the error msg I keep getting. Seems as if its not loading properly.

Package index broken
Error: Command failed: “C:\Users\Jeff Holly Bevan\AppData\Local\Programs\XOD IDE\resources\arduino-cli.exe” --config-file=C:\Users\Jeff Holly Bevan\AppData\Local\Temp\arduino-cli2t6a9o.cli-config.yml config dump Error: unknown command “Holly” for “arduino-cli” Run ‘arduino-cli --help’ for usage. "C:\Users\Jeff Holly Bevan\AppData\Local\Programs\XOD IDE\resources\arduino-cli.exe" --config-file=C:\Users\Jeff Holly Bevan\AppData\Local\Temp\arduino-cli2t6a9o\.cli-config.yml config dump (exited with error code 1)
Check correctness of the corresponding URL in “C:\Users\Jeff Holly Bevan\xod_packages_/extra.txt” and try to update indexes again

HELP!


#2

“Unknown command ‘Holly’” would indicate it is unable to deal with spaces in the path name. You will probably have to move your workspace to a different location that doesn’t include spaces.

This could probably be considered a bug that path is not quoted to allow spaces…


#3

could/would this be a simple as renaming the pathname Jeff Holly Bevan to something else with no spaces or just eliminating the spaces in the current path name?


#4

Current pathname is where windows is looking for all your personal stuff, so it would not be trivial to change. XOD has an option File > Switch Workspace. I’m not 100% sure, but I think changing this to a path without spaces would resolve your issue. You will need to copy/move the project you are working on to the new folder.

This may only change your project directory, and not the XOD installed location. You may need to re-install XOD into a new location to fully resolve the issue.


#5

Good catch, gentlemen!

Created an issue about this bug https://github.com/xodio/xod/issues/1723